Radio Infrastructure Upgrade (#TFN-020126)
Resolved
Jan 02 at 05:38pm GMT
Our upgrade has been completed and you can now listen live to both stations as normal.
Affected services
Created
Jan 02 at 05:00pm GMT
The FLOW Network is currently carrying out an upgrade to its radio broadcasting infrastructure as part of ongoing improvements to service reliability and performance.
During this maintenance window, listeners may experience temporary interruptions or be unable to listen live to FLOW Radio and FLOW Xtra across all platforms. No action is required from listeners at this time.
We expect the upgrade to be completed and normal service fully restored by 17:30 GMT on 02 January 2026.
We apologise for any inconvenience caused and thank you for your patience while we work to improve the FLOW listening experience.
Affected services